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METTLE SKYBOX STUDIO V2- USER MANUAL 
SkyBox Studio V2 is a set of 360/VR production tools for Adobe 
After Effects. It is a combination of Scripts & Plugins that let 
artists focus on creating 360 videos in a familiar workspace, while 
Mettle takes care of all the 360 technology and wizardry.
Also generate environment/reflection maps with the same tools. 
Compatible: Mac and WIN 
...............................................................................................

BUY SkyBox Studio V2
 

“Mettle Skybox Studio V2 is an 
amazing package of goodies for 
360 content creators. Life just got 
a lot easier for all of us with this 
new toolset.”
Read the Review by Al Caudullo

WHAT’S NEW in VERSION 2: View-based Edit + Stereo Support, + 
we support more formats, and much more!

http://www.mettle.com/product/skybox-studio-v2/
http://alcaudullo.com/mettle-skybox-studio-v2-hands-on-review/
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Overview:
Mettle SkyBox Studio V2 consists of 7 modules:

SkyBox Converter has been updated for V2 and now supports more formats including: 
Fisheye (FullDome), Cube-Map Facebook 3:2, Cube-Map Pano 2VR 3:2, Cube-Map GearVR 6:1, 
Equirectangular 16:9, as well as Cube-Map 4:3, Sphere Map, and Equirectangular 2:1.

SkyBox Extractor is a script that converts stitched Equirectangular footage into a working 
environment in After Effects where you can motion-track, do object removal, add motion 
graphics, vfx etc. If you are doing more complex and sophisticated 3D motion graphics 
sequences,they  are easier to visualise with SkyBox Extractor than with SkyBox Composer, 
because you can see and control the project in a cube format.

SkyBox Creator is a script that automates the creation of all necessary compositions and 
camera relationships to create a 360 | VR authoring environment in After Effects. 

SkyBox Viewer is a plugin that emulates what you will see in YouTube 360, Oculus Rift, and 
other formats. This is excellent to preview your composites and animations in After Effects. It 
shows one frame at a time.

SkyBox Rotate Sphere is a new plugin that offers the ability to re-orient your element’s 
position in the 360 sphere. Similar to Project 2D, Rotate Sphere is more computationally 
efficient due to its more targeted parameters. Supports Stereoscopic 1:1 Over/Under and 
16:9 footage.

SkyBox Project 2D is a new plugin that offers a quick solution for simple additions to your 
scene, giving you re-orient controls over the source layer as well as the element’s position in 
the 360 sphere. Supports Stereoscopic 1:1 Over/Under and 16:9 footage.

Skybox Studio V2 once again changes the landscape of how the industry works with 360 
degree footage. Mettle is thrilled to bring you ‘View-based Editing’ with Skybox Composer, 
a revolutionary new module that allows you to work with 360 degree content as if it were 
traditional footage, taking the guess work out of adding and placing visual effect elements.  
SkyBox Composer is a powerful new script that offers users ‘View-based Editing’, making your 
360 work fast and efficient. “View” is what you see through a VR Headset or Smartphone. Great 
for simple motion-tracking, object removal, adding motion graphics, vfx etc. 

NEW

NEW

NEW

UP-
DATED-
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HOW TO INSTALL METTLE’S SKYBOX
Simply launch the installer that was sent to you and follow the instructions. Make sure that 
After Effects is located in the default location that the Adobe Creative Cloud Installer has desig-
nated. Nesting After Effects in another location or folder on your drive is not standard practise 
and may result in installation problems. 

 
HOW TO REGISTER METTLE’S SKYBOX
Step 1
In a new Composition, launch After Effects then go to After Effects > Preferences > General 
and make sure that “Allow Scripts to write files and Access network” is checked. 

Step 2 
Simply apply SkyBox Converter to any After Effects layer, then click on the Register window 
and add your email address and license key exactly as it was sent to you by email when you 
purchased SkyBox Studio V2. (You may also find a ‘Register’ link at the top of the Effect Controls 
window, above the Converter parameters.)

NOTE: To use SkyBox Studio V2 on more than one computer you need to either 
buy more activations or go to the Register Window and click “Deactivate” . You 
can then “Activate” your license on another system.

QUICK TIP: Please make sure to 
disable any anti-virus software tempo-
rarily to assure a proper install.
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HOW TO USE SKYBOX COMPOSER
Composer is an excellent option for keeping things efficient in the compartmentalized 
landscape of film, television, and video game production. With Composer, you are now able 
to export traditional, 16:9, non-warped images, allowing you to leverage the strengths of 
your Photoshop or Compositing artists for tasks such as paint-out or rig removals. Composer 
allows these key talents to be part of the 360 degree workflow without having step outside the 
software package that they’re comfortable with.
Alternately, you can use the same approach to simply allow your After Effects artists a ‘cleaner’ 
view for using tools like the Clone Tool. (To learn more about After Effects’ Clone Tool see: 
https://helpxadobe.com/after-effects/using/paint-tools-brush-clone-stamp.html#clone_
stamp_tool )

Step 1
Drag your Equirectangular footage into a new composition.

Step 2
With your 360 footage selected, go to the top menu of After Effects and choose Window> 
Skybox Composer.jsxbin. Depending on your workspace layout, you should see the panel open 
on the right, near your Effects & Presets panel.

Footage Courtesy www.unifiedpictures.com, Tim Montijo

NEW

https://helpxadobe.com/after-effects/using/paint-tools-brush-clone-stamp.html#clone_stamp_tool
https://helpxadobe.com/after-effects/using/paint-tools-brush-clone-stamp.html#clone_stamp_tool
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Footage Courtesy www.unifiedpictures.com, Tim Montijo

Choosing either option will open a new dialogue window, allowing you to adjust size and 
aspect ratio settings for your added element independently of the size and aspect ratio settings 
of your composition window. Make sure the “Select a composition with 360 footage:” drop-
down menu has the correct composition selected.
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Click ‘Add 2D Edit’ or ‘Add 3D Edit’. On the right side, you’ll see additional buttons appear. This is 
where you will select which composition window is active.

QUICK TIP:  If you chose ‘Add 3D Edit’ at Step 3, then make the ele-
ment that you add in Step 6 into a 3D Layer via the 3D Layer toggle and 
position the element in X, Y, or Z space as desired.

QUICK TIP: Use the buttons in the Composer panel to select which composition window you wish 
to make active. By pressing the ‘Edit 1’ button,  the ‘Edit 1’ Composition becomes active. Now you may 
work directly in the ‘Edit 1’ Composition window. By pressing ‘Open Output/Render’, your Equirect-
angular Composition should become active and update itself, making your additions to the ‘Edit 1’ 
Composition visible and appear properly warped to match the Equirectangular layout.
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QUICK TIP: When working with masks, 
duplicate the bottom layer, place the dupli-
cate above the element that you are adding 
to your composition, then subtract the parts 
that you want to make invisible from the 
duplicate, rather than applying a mask to 
the new element layer.

You will see that Composer has created two new composition timelines, one for the ‘Edit 1’ 
Composition and one for the ‘Output’ Composition.

Looking at the newly created ‘Edit 1’ Composition, you will also see that a new camera, the 
‘Skybox Master Camera’, has been created in your timeline. The footage in your ‘Edit 1’ Compo-
sition window now appears as non-warped, 16:9, traditionally shot footage, rather than the 
Equirectangular layout seen in your ‘Output’ Composition.
Step 4
This step is optional, but we recommend opening a second composition window and placing 
it beside the first, allowing you to see your ‘Edit 1’ Composition window (a 16:9 view of your 
footage) and your ‘Output’ Composition window (the Equirectangular view of your footage) 
side by side.
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Footage courtesy: FisheyeVR

Step 5
In your ‘Edit 1’ Composition window, use the After Effects camera tool to click and drag, orbiting 
your Field of View to see it as it would look to an end user with a Virtual Reality headset such as 
a PSVR, Occulus Rift, HTC Vive and more. Much like the Skybox Viewer module, this will allow 
you to ‘reframe’ your Field of View, in order to find the specific Field of View in your 360 degree 
footage that you would like to add elements to.  

Step 6
Add your element, whether that is a visual effect or text element, animated or not, directly to 
your ‘Edit 1’ Composition. You should be able to see that element also appear in the ‘Output’ 
Composition, with the necessary Equirectangular warp applied to the element (if not, click the 
Open Output/Render button on the right to refresh the ‘Output’ Composition window). Now, 
you are ready to output your final video. 

QUICK TIP: If you chose ‘Add 3D Edit’ at Step 
3, then make the element that you add in 
Step 6 into a 3D Layer via the 3D Layer toggle 
and position the element in X, Y, or Z space as 
desired.

QUICK TIP:  SkyBox Composer - Best Practises
For 2D editing
Create a Edit 2 instance… use the AE camera to point at a view you wish to work on… clone or add 2D element.
Create another Edit 2 instance… use the AE camera to point at another view you wish to work on… clone or add another 2D 
element.  etc.  Make sure you use the SkyBox Composer Interface to navigate the Edit and Output comps for best results.

For 3D Editing
Create a Edit 3 instance… use the AE camera to point at a view you wish to work on… add 3D element. 
In this case, you can point at another view and continue to populate with 3D assets. 
Make sure you use the SkyBox Composer Interface to navigate the Edit and Output comps for best results.
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HOW TO USE SKYBOX PROJECT 2D
Skybox Project 2D is a great new feature that makes adding 2D elements to your project 
even easier! This is a fantastic option for integrating logos, text, and other 2D elements quickly 
and efficiently. You can even use it with additional footage, such as animated visual effect or 
motion graphic elements. It is a great option for those who need a straight-forward, linear 
workflow. Works with monoscopic and stereoscopic footage.

Step 1
Import or create the 2D element that you want to add to your composition.

Step 2
From the Effects & Presets window, apply the Skybox Project 2D to your 2D element layer.

NEW
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Step 3
Adjust your Effect Controls parameters as desired. These include:
Frame layout
- Monoscopic is for non-stereo(non 3D) output.
- Stereoscopic is for stereo 3D output. This setup uses Over/Under for its 3D layout.

Scale (Degrees)
This allows you to adjust the size of your element. Use these controls rather than the 
element’s native Transform parameters.

Stereo Disparity (Degrees)
This allows you to set the distance between the left and right view to increase or decrease 
the amount of the 3D ‘pop out’ effect. This is keyable to allow for a change in the stereo 
effect over time.

Rotate Source
These are keyable attributes to adjust the X, Y, or Z rotation of the added element accord-
ing to its own anchor point

Rotate Projection
These are keyable attributes to adjust the X, Y, or Z rotation of the element’s position 
within the 360 degree spherical environment, by assuming an anchor point at the centre 
of the 360 degree spherical environment.

HOW TO USE SKYBOX ROTATE SPHERE
Skybox Rotate Sphere is a feature similar to Project 2D, in that it allows you to use 
keyable attributes to adjust the X, Y, or Z rotation of the element’s position within the 
360 degree spherical environment. Its functionality is limited to these parameters in 
order to keep things computationally light for busy production companies and tight 
delivery schedules. Works with monoscopic and stereoscopic footage.

Adjust your Effect Controls parameters as desired. These include:
Frame layout
- Monoscopic is for non-stereo(non 3D) output.
- Stereoscopic is for stereo 3D output. This setup uses Over/Under for its 3D layout.

These are keyable attributes to adjust the X, Y, or Z rotation of the added element 
according to its own anchor point. No need to re-stitch your camera views or adjust your 
shoot just to change the camera orientation.
These controls are keyframeable, so animated Camera Tilts, Pans, and Rolls are possible 
as well.

Invert Rotation
Takes all the values for the Tilt, Pan and Roll, and inverts them.

NEW
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Tilt (X axis), Pan (Y axis), Roll (Z axis) can be used to readjust the focal point and 
straighten the horizon, and add camera movement in post. Keyframeable.
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HOW TO USE SKYBOX CONVERTER
SkyBox Converter is an After Effects Plugin. As such, you can load it from Effect  > Mettle 
> Mettle SkyBox Converter.  

You can use SkyBox Converter in conjunction with all the other SkyBox modules. You can also 
use SkyBox Converter on its own if you want to convert images in your stock library from Cubic 
to Spherical, Equirectangular, or many other layout options. You can also change the camera 
orientation in your footage. Or even add simple supers, logos, or image patches that you 
retouch in Photoshop to your footage.

SkyBox Converter Can Convert Between Various Formats 
The “Input” should match the original format, then select the “Output” format you wish to 
convert to and SkyBox Converter will take care of the rest.

UP-
DATED-

NEW NEW

Facebook 3:2

NEW INPUT FORMATS IN V2:
Fisheye (FullDome), Cube-map Facebook 3:2), Cube-map 
Pano2VR 3:2, Cube-map GearVR 6:1, Equirectangular 16:9. The 
original formats from Version 1 are also included:  2D Source, 
Cube-map 4:3, Sphere-map, Equirectangular 2:1.

NEW OUTPUT FORMATS IN V2:
Cube-map Facebook 3:2), Cube-map Pano2VR 3:2, Cube-map 
GearVR 6:1, Equirectangular 16:9. The original formats from 
Version 1 are also included:  Fisheye (FullDome), Cube-map 4:3, 
Sphere-map, Equirectangular 2:1.

SKYBOX CONVERTER FORMATS
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NEW NEW

NEW
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SkyBox Converter: Re-orient Camera View
Tilt (X-Axis), Pan (Y Axis), and Roll (Z Axis) controls are available in SkyBox Converter. No need 
to re-stitch your camera views or adjust your shoot just to change the camera orientation. One 
possible use is pictured below. In this case, the camera rig faces the front view of the automo-
bile. With a simple Pan (180 degree rotation on the Y Axis), our view now faces the car. 
 
These controls are keyframeable, so animated Camera Tilts, Pans, and Rolls are possible as 
well. 

Footage courtesy Ben Kidd - Hamilton+Kidd 
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SkyBox Converter - Input - 2D Source
On many occasions 360 | VR productions may call for you to either add watermarks to your 360 
footage, add simple supers, or even logos. This feature in Converter will come in very handy. 
Pictured below is one use of 2D Source as an Input type.  
 
This example consists of a pre-composition, “Supers & Logos”. This pre-comp needs to be 
created to the same size as your master, in this case 4096 x 2048 pixels. We added After Effects 
text and the Mettle Logo. This pre-comp is then added to your master comp that contains your 
stitched 360 footage. SkyBox Converter is applied to this “Supers & Logos” layer and we simply 
added a Camera tilt (X Axis) to position the text on top of the hood of the car. Animation is 
possible both in the pre-comp as well as via the Re-orient camera controls. 

Footage courtesy Ben Kidd - Hamilton+Kidd 
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HOW TO USE SKYBOX CREATOR
Step 1
To launch SkyBox Creator simply go to: File > Scripts > SkyBox Creator.jsx.bin. If you wish to 
create a new SkyBox Master from scratch then choose the size you need, 1024 x 1024 will do for 
most applications of SkyBox. 

Step 2
Choose the frame rate and duration of your SkyBox Master, then click on “Create SkyBox 
Master”.
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Step 3
At the bottom of your Composition window, switch your Camera View to Custom View 1 and 
proceed to create your SkyBox world by adding your favorite After Effects 3D plugins and/
or 3D layers. In the screen capture on the previous page, we added Trapcode Horizon, Form & 
Rowbyte’s Plexus. 

Step 4
Once you are happy with your creation, simply click on “Generate SkyBox Output”. SkyBox 
Creator takes over from here and creates all the necessary compositions, adds all the cameras 
and distortion, as well as all of the expressions that are required to create a Cubic Map. You can 
then use SkyBox Converter to switch between various output formats. (See section on SkyBox 
Converter.) 
 
Step 5 
At the bottom of your Composition window, you can switch your display from 1 View to 4 
Views. This will help you verify that objects are in frame in all 6 views. Try to avoid having 
things come too close to the centre of your scene, clipping on one or more of the views may 
occur or, one or more of the views may be obscured. Adjusting the 3D plugin parameters will 
help you avoid this issue. 
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Step 6
Want to modify your SkyBox Master and apply these changes to your ‘SkyBox Output’ Com-
position? Simply click on ‘Refresh SkyBox Output’ once you are done with your modifications. 
SkyBox Creator will take care of deleting all comps and recreating them based on the last set of 
modifications you made to your ‘SkyBox Master’ Composition.
 
Use the “3D Null | Camera Control” if you know you want to control your SkyBox Camera via 
a 3D Null layer. Using the pick whip to Parent to the After Effects camera will not work well. This 
must be done via a proper Expression however, we made it simple for you - just make sure that 
this check box is selected. 
 
Make sure to keep the “I am using 3D Plugins” box checked if you know that you will be 
using 3D plugins.  

Some 3D plugins like Mettle’s FreeForm Pro, Shapeshifter,  Video Copilot’s Element 3D, Trapcode 
Mir, are true 3D plugins so they do not need the “Edge Blending” enabled. Others like, Row-
byte’s Plexus, Trapcode 3D Stroke, Form & Particular exhibit issues at times. This is where “Edge 
Blending”  can help, but it will not comletely resolve the issues. Ultimately Boris, Cycore Sys-
tems, Rowbyte, and Trapcode (and others) need to address this, in the code of their offerings.

QUICK TIP: Due to the After Effects architecture, thrid party 3D plugins, and even 
After Effects’s very own Shatter are treated very differently than After Effects 3D 
layers. As a result, SkyBox Creator will set things up very differently if you plan 
on only using After Effects 3D layers versus including 3D plugins.
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 HOW TO USE SKYBOX EXTRACTOR 
SkyBox Extractor makes dealing with stitched 360 footage easy. SkyBox Extractor is a Scripted 
solution.

To access SkyBox Extractor go to File > Scripts > SkyBox Extractor.

SkyBox Extractor removes the Equirectangular distortion in 360 footage 
and then extracts 6 camera views. Extractor then positions them in a cube 
formation in After Effects in a ‘SkyBox Edit’ Composition (pictured below).

In the ‘SkyBox Edit’ Composition, you can render the view(s) you need so that 
you can motion track or camera track them more easily. You can also do object 
removal, add motion graphics, CG, VFX, etc. SkyBox Studio modules play well 
with third party 3D products like Mettle’s FreeForm Pro, ShapeShifter, Video 
CoPilot’s Element 3D, Trapcode products etc. Notice that Extractor adds a 
Master SkyBox Camera as well as 6 more camera views that are parented to 
the Master Camera. Also notice that we generate 6 “Faces”... Front, Right, Back, 
Top, Left, and Bottom. These are strategically positioned to form the cube you 
see pictured here. 

Footage courtesy Ben Kidd - Hamilton+Kidd 
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SkyBox Extractor creates a ‘SkyBox Output’ Composition. This is what you will render out for YouTube 360 etc. once you are finished your work. All the work you 
do in your ‘SkyBox Edit’ Composition will make its way through to the ‘SkyBox Output’ Composition. SkyBox Extractor harnesses the power of SkyBox Converter 
to convert from a Cube Map layout (as is set up in the ‘SkyBox Edit’ Composition) to Equirectangular, which is necessary for YouTube 360 and many other 360 | VR 
formats.

SkyBox Extractor adds a ‘SkyBox Viewer’ Composition. SkyBox Viewer is another module, built to simulate the view that you see in YouTube 360 and other 360 | 
VR formats. This is an excellent way to check you work before rendering out, compressing, and uploading it to your preferred 360 players.

Footage courtesy Ben Kidd - Hamilton+Kidd 
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 HOW TO USE SKYBOX VIEWER 
SkyBox Viewer is a plugin lets you preview your camera’s point of view in After Effects. Orbit 
around your scene using the Camera Orbit Tool. This is a stationary view of a single frame, 
non-animated. 
You can load it from Effect  > Mettle > Mettle SkyBox Viewer  
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PREPARING YOUR SKYBOX CREATION FOR YOUTUBE 360
Mettle SkyBox is excellent in helping you get your SkyBox creations from After Effects into the 
YouTube 360 format quickly and efficiently. Make sure you export your project in the Equirect-
angular format, with meta-data injected. 
See: https://support.google.com/youtube/answer/6178631?hl=en 

Written by: 
Chris Bobotis and A.J. King Thank you for choosing Mettle Skybox Studio V2!

................................................................................................
Use SkyBox generated Maps with: 
After Effects 3D PLUG-INS
You can create reflection maps and/or environment maps for use with After Effects 3D plugins 
like Element 3D, FreeForm Pro, Shapeshifter & Zaxwerks. Pretty much any 3D plugin that will 
accept and use AE layers as reflection or environment maps. 

3D APPLICATIONS
Use these reflection maps and/or environment maps with 3D applications like 3ds Max, 
Blender, Cinema 4D, Lightwave, Maya, Modo etc. Create amazing environments by tapping into 
the rich motion graphics offerings in After Effects to generate stills and sequences that cannot 
be done as easily in 3D.

3D GAMES
Use SkyBox with the Unreal Engine or Unity 3D to create elements for your level design. Create 
a unique world of your own.

WEBGL
SkyBoxes have been supported in hardware in openGL and now in webGL for quite a while. 
With Mettle’s SkyBox you can now create rich & unique environments using After Effects for 
your webGL projects. 

VR APPLICATIONS LIKE OCULUS RIFT, SAMSUNG GEAR VR
SkyBox Converter can convert to the Equirectangular format that many VR applications like 
Oculus Rift require.
 

https://support.google.com/youtube/answer/6178631?hl=en 

